Arief Yudhawarman

Masih belajar buat blog

Instalasi Access Point Manager Mikrotik (CAPsMAN)

with one comment


Pengantar

Implementasi jaringan wireless pada area kerja yang luas tentu akan membutuhkan banyak Access Point (AP).
Efeknya pekerjaan konfigurasi seperti setup SSID, pengaturan frekuensi, access list dan lain-lain akan bertambah pula. Mulai versi ROS v6.11, Mikrotik memperkaya lagi fitur yang sudah ada dengan menambahkan sebuah fitur yang dinamakan CAPsMAN (Controller Access Point system Manager). Fitur ini banyak ditunggu oleh para pengguna Mikrotik, khususnya bagi yang memiliki jaringan wireless skala besar.

CAPsMAN (Controller Access Point system Manager) merupakan sebuah fitur wireless controller yang memudahkan kita untuk mengatur semua perangkat wireless akses point yang ada dijaringan kita secara terpusat.

Dalam penggunaan CAPsMAN ini, nanti perangkat-perangkat yang akan kita gunakan memiliki 2 istilah:

  • CAP (Controlled Access Point), yaitu perangkat wireless akses point yang akan kita konfigurasi terpusat
  • System Manager (CAPsMAN), yaitu perangkat yang digunakan untuk mengatur CAP. Konfigurasi, authentikasi dan sebagainya bisa diatur dari perangkat ini.



Sekilas Cara Kerja CAPsMAN

Agar CAPsMAN sistem ini berfungsi, perangkat yang menjadi CAP harus membentuk koneksi manajemen ke perangkat yang menjadi CAPsMAN. Komunikasi antara CAPsMAN dan CAP bisa dibentuk dengan 2 metode:

  • Menggunakan MAC, komunikasi bisa terbentuk apabila CAP dan CAPsMAN masih berada dalam segment layer 2 yang sama (baik fisik ataupun layer 2 tunnel).
  • Menggunakan IP (protocol UDP), komunikasi ini digunakan apabila antara CAP dan CAPsMAN sudah berbeda segment Layer 2 (melewati router lain). Dengan menggunakan metode ini maka antara CAP dan CAPsMAN tidak perlu berada dalam sebuah network yang sama, bahkan bisa berbeda lokasi geografis.

Dalam kasus ini karena CAPsMAN dan CAP berada dalam satu segmen yang sama maka akan dipakai metode pertama.


Topologi

Pada kasus ini kita menggunakan Virtual AP untuk melayani tiga jaringan wireless yang berbeda (LAN A, LAN B dan HOTSPOT).

Router Mikrotik

  • WAN: 10.10.10.2/30
  • TRUNK: 192.168.100.1/24
    • LAN A
      • VLANID: 10
      • IP Address: 192.168.10.254/24
      • SSID: SSIDLANA
    • LAN B
      • VLANID: 20
      • IP Address: 192.168.20.254/24
      • SSID: SSIDLANB
    • HOTSPOT
      • VLANID: 30
      • IP Address: 172.16.30.254/24
      • SSID: SSIDHOTSPOT
    • CAP
      • VLANID: 99
      • IP Address: 192.168.99.62/26

CAPsMAN

  • Interface : ether1
  • IP Address : 192.168.99.27/26

CAP 1

  • Interface : ether1
  • IP Address : 192.168.99.1/26
  • WLAN Mac Address: 00:0C:42:EE:01:00

CAP 2

  • Interface : ether1
  • IP Address : 192.168.99.2/26
  • WLAN Mac Address: 00:0C:42:EE:02:00

CAP 3

  • Interface : ether1
  • IP Address : 192.168.99.3/26
  • WLAN Mac Address: 00:0C:42:EE:03:00

CAP 4

  • Interface : ether1
  • IP Address : 192.168.99.4/26
  • WLAN Mac Address: 00:0C:42:EE:04:00

CAP 5

  • Interface : ether1
  • IP Address : 192.168.99.5/26
  • WLAN Mac Address: 00:0C:42:EE:05:00

CAP 6

  • Interface : ether1
  • IP Address : 192.168.99.6/26
  • WLAN Mac Address: 00:0C:42:EE:06:00

Note: IP Address CAP diset statik di ip dhcp-server lease.

Topologi Network

Topologi Network


Topologi CAPsMAN

Topologi CAPsMAN


Topologi Switch Management

Topologi Switch Management


Persyaratan

Untuk instalasi ini baik CAPsMAN maupun CAP sebaiknya menggunakan ROS versi yang sama. Di sini penulis menggunakan ROS version 6.35. Kemudian di system package enable package wireless-cm2 (secara otomatis package wireless-fp akan disable) kemudian reboot device.

Package List

Package List

Router mikrotik yang akan menjadi wireless controller (CAPsMAN) sebaiknya yang memiliki high processor seperti RB1100AHx2, mengingat router ini akan mengontrol banyak akses point. Router ini boleh tidak memiliki interface wireless. Di sini penulis menggunakan RB433GL yang sudah dilepas perangkat radionya. Kemudian untuk device mikrotik yang akan difungsikan sebagai CAP (Controlled Access Point) bisa menggunakan RB751U-2HnD, RB951G-2HnD atau routerboard cAP (ceiling Access Point) series yang khusus untuk dipasang di ceiling atau langit-langit seperti RBcAP2n atau RBcAP2nD.

RBcAP2nD

RBcAP2nD


Konfigurasi

Router

/ip address
add address=10.10.10.2/30 interface=WAN network=10.10.10.0
add address=192.168.100.254/24 interface=LAN network=192.168.100.0
add address=192.168.99.62/26 interface=CAP network=192.168.99.0
add address=192.168.10.254/24 interface=LANA network=192.168.10.0
add address=192.168.20.254/24 interface=LANB network=192.168.20.0
add address=172.16.30.254/24 interface=HOTSPOT network=172.16.30.0

/interface vlan
add interface=LAN l2mtu=1594 name=LANA vlan-id=10
add interface=LAN l2mtu=1594 name=LANB vlan-id=20
add interface=LAN l2mtu=1594 name=HOTSPOT vlan-id=30
add interface=LAN l2mtu=1594 name=CAP vlan-id=99

/ip pool
add name=dhcp_pool1 ranges=192.168.10.1-192.168.10.253
add name=dhcp_pool2 ranges=192.168.20.1-192.168.20.253
add name=dhcp_pool3 ranges=172.16.30.1-172.16.30.253
add name=dhcp_pool4 ranges=192.168.99.1-192.168.99.26

/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=LANA lease-time=1d name=dhcp1
add address-pool=dhcp_pool2 disabled=no interface=LANB lease-time=1d name=dhcp2
add address-pool=dhcp_pool3 disabled=no interface=HOTSPOT lease-time=1d name=dhcp3
add address-pool=dhcp_pool4 disabled=no interface=CAP lease-time=1d name=dhcp4



CAPsMAN

Wireless controller pada router mikrotik yang dijalankan dengan CAPsMAN menggunakan logika tunneling. Saat sebuah access point terdaftar ke CAPsMAN maka akan terbentuk sebuah tunnel antara CAPsMAN dengan interface wlan pada CAP. Sehingga seakan-akan interface wlan dari CAP seperti berada pada router yang menjalankan CAPsMAN. Ilustrasi seperti pada gambar di bawah.

Tunnel antara CAP dengan CAPsMAN

Tunnel antara CAP dengan CAPsMAN

Tunneling yang terbentuk antara CAPsMAN dan CAP akan bertemu pada satu interface yang dinamakan datapath.bridge sehingga seluruh trafik dari CAP akan mengalir melalui interface ini.

Ada dua parameter yang mengatur trafik client wireless yang terhubung pada CAP. Kedua parameter tersebut adalah datapatah.client-to-client-forwarding dan datapath.local-forwarding. Pada tulisan ini datapatah.client-to-client-forwarding akan diset enable (dicentang) sehingga sesama client wireless bisa saling komunikasi kecuali untuk jaringan hotspot akan diset disable (tidak dicentang). Kemudian datapath.local-forwarding akan diset disable (tidak dicentang) sehingga trafik dari client wireless akan mengalir terlebih dahulu melalui datapath.bridge meski jika trafik itu terjadi antara sesama client wireless yang terhubung ke CAP yang sama.

CAPsMAN's datapath.bridge

CAPsMAN’s datapath.bridge

/interface vlan
add interface=ether1 l2mtu=1516 name=LANA vlan-id=20
add interface=ether1 l2mtu=1516 name=LANB vlan-id=86
add interface=ether1 l2mtu=1516 name=HOTSPOT vlan-id=68

/interface bridge
add mtu=1500 name=bridge1
add mtu=1500 name=bridge2
add mtu=1500 name=bridge3

/interface bridge port
add bridge=bridge1 interface=LANA
add bridge=bridge2 interface=LANB
add bridge=bridge3 interface=HOTSPOT

/interface bridge settings
set use-ip-firewall=yes use-ip-firewall-for-vlan=yes

/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1

/caps-man channel
add band=2ghz-onlyn frequency=2412 name=channel1 width=20
add band=2ghz-onlyn frequency=2417 name=channel2 width=20
add band=2ghz-onlyn frequency=2422 name=channel3 width=20
add band=2ghz-onlyn frequency=2427 name=channel4 width=20
add band=2ghz-onlyn frequency=2432 name=channel5 width=20
add band=2ghz-onlyn frequency=2437 name=channel6 width=20
add band=2ghz-onlyn frequency=2442 name=channel7 width=20
add band=2ghz-onlyn frequency=2447 name=channel8 width=20
add band=2ghz-onlyn frequency=2452 name=channel9 width=20
add band=2ghz-onlyn frequency=2457 name=channel10 width=20
add band=2ghz-onlyn frequency=2462 name=channel11 width=20
add band=2ghz-onlyn frequency=2467 name=channel12 width=20
add band=2ghz-onlyn frequency=2472 name=channel13 width=20

/caps-man security
add authentication-types=wpa-eap,wpa2-eap eap-methods=passthrough encryption=aes-ccm,tkip \
  group-encryption=aes-ccm name=lana tls-certificate=none tls-mode=dont-verify-certificate
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm,tkip group-encryption=aes-ccm \
  name=lanb passphrase=passwordwifi
add authentication-types=wpa-psk,wpa2-psk encryption=aes-ccm,tkip group-encryption=aes-ccm \
  name=hotspot passphrase=passwordwifi

/caps-man configuration
add country=indonesia \
  datapath.bridge=bridge1 \
  datapath.client-to-client-forwarding=yes \
  datapath.local-forwarding=no \
  mode=ap name=LANA security=lana ssid=SSIDLANA
add datapath.bridge=bridge2 \
  datapath.client-to-client-forwarding=yes \
  datapath.local-forwarding=no \
  name=LANB security=lanb ssid=SSIDLANB
add datapath.bridge=bridge3 \
  datapath.client-to-client-forwarding=no \
  datapath.local-forwarding=no \
  name=HOTSPOT security=hotspot ssid=SSIDHOTSPOT


Kemudian set caps-man provisioning untuk semua cap yang akan dikonfigur oleh CAPsMAN.

/caps-man provisioning
add action=create-dynamic-enabled comment="AP1" master-configuration=LANA \
  name-format=prefix name-prefix=AP radio-mac=00:0C:42:EE:01:00
add action=create-dynamic-enabled comment="AP2" master-configuration=LANA \
  name-format=prefix name-prefix=AP radio-mac=00:0C:42:EE:02:00
add action=create-dynamic-enabled comment="AP3" master-configuration=LANA \
  name-format=prefix name-prefix=AP radio-mac=00:0C:42:EE:03:00
add action=create-dynamic-enabled comment="AP4" master-configuration=LANA \
  name-format=prefix name-prefix=AP radio-mac=00:0C:42:EE:04:00
add action=create-dynamic-enabled comment="AP5" master-configuration=LANA \
  name-format=prefix name-prefix=AP radio-mac=00:0C:42:EE:05:00
add action=create-dynamic-enabled comment="AP6" master-configuration=LANA \
  name-format=prefix name-prefix=AP radio-mac=00:0C:42:EE:06:00


Kemudian untuk Tx power dan channel caps-man interface akan diatur sebagai berikut:

  1. CAP 1
    • Tx Power: 12dbm
    • Channel: 1
  2. CAP 2
    • Tx Power: 12dbm
    • Channel: 6
  3. CAP 3
    • Tx Power: 12dbm
    • Channel: 11
  4. CAP 4
    • Tx Power: 12dbm
    • Channel: 1
  5. CAP 5
    • Tx Power: 12dbm
    • Channel: 6
  6. CAP 6
    • Tx Power: 12dbm
    • Channel: 11
/caps-man interface
add arp=enabled channel=channel1 channel.tx-power=12 comment="AP1" configuration=LANA \
    configuration.country=indonesia disabled=no l2mtu=1600 mac-address=00:0C:42:EE:01:00 \
    master-interface=none mtu=1500 name=AP1 radio-mac=00:0C:42:EE:01:00
add arp=enabled configuration=LANB disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP1-1 radio-mac=00:00:00:00:00:00
add arp=enabled configuration=HOTSPOT disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP1-2 radio-mac=00:00:00:00:00:00
add arp=enabled channel=channel6 channel.tx-power=12 comment="AP2" configuration=LANA \
    configuration.country=indonesia disabled=no l2mtu=1600 mac-address=00:0C:42:EE:02:00 \
    master-interface=none mtu=1500 name=AP2 radio-mac=00:0C:42:EE:02:00
add arp=enabled configuration=LANB disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP2-1 radio-mac=00:00:00:00:00:00
add arp=enabled configuration=HOTSPOT disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP2-2 radio-mac=00:00:00:00:00:00
add arp=enabled channel=channel11 channel.tx-power=12 comment="AP3" configuration=LANA \
    configuration.country=indonesia disabled=no l2mtu=1600 mac-address=00:0C:42:EE:03:00 \
    master-interface=none mtu=1500 name=AP3 radio-mac=00:0C:42:EE:03:00
add arp=enabled configuration=LANB disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP3-1 radio-mac=00:00:00:00:00:00
add arp=enabled configuration=HOTSPOT disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP3-2 radio-mac=00:00:00:00:00:00
add arp=enabled channel=channel1 channel.tx-power=12 comment="AP4" configuration=LANA \
    configuration.country=indonesia disabled=no l2mtu=1600 mac-address=00:0C:42:EE:04:00 \
    master-interface=none mtu=1500 name=AP4 radio-mac=00:0C:42:EE:04:00
add arp=enabled configuration=LANB disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP4-1 radio-mac=00:00:00:00:00:00
add arp=enabled configuration=HOTSPOT disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP4-2 radio-mac=00:00:00:00:00:00
add arp=enabled channel=channel6 channel.tx-power=12 comment="AP5" configuration=LANA \
    configuration.country=indonesia disabled=no l2mtu=1600 mac-address=00:0C:42:EE:05:00 \
    master-interface=none mtu=1500 name=AP5 radio-mac=00:0C:42:EE:05:00
add arp=enabled configuration=LANB disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP5-1 radio-mac=00:00:00:00:00:00
add arp=enabled configuration=HOTSPOT disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP5-2 radio-mac=00:00:00:00:00:00
add arp=enabled channel=channel11 channel.tx-power=12 comment="AP6" configuration=LANA \
    configuration.country=indonesia disabled=no l2mtu=1600 mac-address=00:0C:42:EE:06:00 \
    master-interface=none mtu=1500 name=AP6 radio-mac=00:0C:42:EE:06:00
add arp=enabled configuration=LANB disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP6-1 radio-mac=00:00:00:00:00:00
add arp=enabled configuration=HOTSPOT disabled=no l2mtu=1600 mac-address=00:00:00:00:00:00 \
    master-interface=AP1 mtu=1500 name=AP6-2 radio-mac=00:00:00:00:00:00


Batasi minimum signal Rx (receive) yang diterima dari client wireless sehingga jika kurang dari power tersebut client akan dikick.

/caps-man access-list
add action=accept interface=all signal-range=-78..120
add action=reject interface=all signal-range=-120..-79



CAP

/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no interface=ether1

/interface wireless cap
set discovery-interfaces=ether1 enabled=yes interfaces=wlan1

Setup CAP

Setup CAP

CAPsMAN Interface

CAPsMAN Interface

Flag – Flag pada CAPsMAN Interface memiliki arti :

  • R (Running): Ada wireless client yang sudah terkoneksi
  • S (Slave): interface ini tergabung dalam sebuah bridge
  • M (Master): interface fisik (bukan VAP)
  • B (Bound): interface wireless CAP sudah aktif pada CAPsMAN

CAPsMAN Provisioning

CAPsMAN Provisioning



CAPsMAN Remote CAP

CAPsMAN Remote CAP



CAPsMAN Registration Table

CAPsMAN Registration Table



Dengan konfigurasi lebih lanjut kita dapat terapkan queue simple di CAPsMAN untuk membatasi trafik upstream dan downstream dari client wireless.
CAPsMAN Queue Simple

CAPsMAN Queue Simple


Referensi:

  1. Artikel Pengenalan CAPsMAN
  2. CAPsMAN Case Study
  3. Router Mikrotik: Implementasi Wireless LAN Indoor, Rendra Towidjojo & Mohammad Eno Farhan, Penerbit Jasakom



Artikel Selanjutnya

Aplikasi Web Mikrotik CapsMan Controller Powered by jQuery & Ajax

Mikrotik CAPsMAN Controller

Mikrotik CAPsMAN Controller



Mikrotik CAPsMAN Controller

Mikrotik CAPsMAN Controller



Mikrotik CAPsMAN Controller

Mikrotik CAPsMAN Controller



Mikrotik CAPsMAN Controller

Mikrotik CAPsMAN Controller



Penampakan video Aplikasi Web Mikrotik CAPsMAN Controller

Advertisements

Written by awarmanf

February 28, 2018 at 2:08 pm

Posted in cap, CAPsMAN, Mikrotik, Wireless

Tagged with , , ,

One Response

Subscribe to comments with RSS.

  1. […] kesempatan yang lalu penulis telah membuat artikel Instalasi Access Point Manager Mikrotik (CAPsMAN). Jika instalasi telah berhasil dan mikrotik wireless yang dikonfigur sebagai CAP telah terintegrasi […]


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: